に対応していません。WordPress を使うには Cookie を有効にする必要があります。+表題のエラーが出てログイン出来ないよ!!と言われてなんだろうと思って調べて、対処した話。

取りあえずhttp://www.example.com/wp-adminにアクセスすると真っ白ページに表示される。それからphp_errors.logに以下のように出力されていた。

[12-May-2014 01:44:32 UTC] PHP Warning: Cannot modify header information - headers already sent in /var/www/wordpress/wp-login.php on line 427

で、結局

  1. Wordpress入れ替え
  2. wp-config.phpだけを新しい方に置き換え
  3. ここでDBの更新が走る
  4. ログイン出来る事を確認
  5. themesを新しい方にコピー
  6. pluginsを新しい方にコピー -> エラー再現
  7. pluginsフォルダーを元に戻す
  8. pluginsフォルダー内にある個々のプラグインを一つずつ新しい方にコピー&エラーが出来るかどうか調べる
  9. 結果、rss-image-feedというプラグインがエラーを出していました

上記プラグインを使っていてエラーになったら上記方法を試してみてください。